View Site link from Ghost Admin returning IP/refused to connect message

Using Ghost 3.32.1, installed via Bitnami AMI on AWS EC2 instance

I have recently installed Ghost via Bitnami AMI on AWS. I have updated all links in Ghost Admin to use my domain name instead of the IP provisioned when the instance was created, and they appear to be working.

However, the link opened when clicking the “View Site” link in Ghost Admin still appears to point to my EC2 instance IP and not my domain name. In the side window, I get a “xxx.xxx.xxx.xxx refused to connect” message (where the xxx part is my IP address), but when I click the link to launch the site in a new window, the site loads correctly (via IP, but it does resolve)

Is there an additional config setting I need to change?

It looks like your ghost url is configured as your IP address :slight_smile: You’ll need to update it using the CLI:

thank you!