Website preview not showing up in iOS Messages app

When I first started my free Ghost account, and shared the URL, a preview image showed up just fine:

Then I added lots of content, and bought a premium Ghost theme. Now when I share the homepage URL I get this:

Is this due to the way the premium theme has been designed? Or is there a different cause?

Thank you.

That page is missing the image that should be provided by meta tags. You can set those under settings > metadata , facebook card, and twitter card. You should also upload a cover image under settings > design and branding.

I checked the metadata section under settings and just see these two fields:

I do see a place for adding a cover image, but when I do, this image becomes the entire background of my webpage. I assume that is a bug in the theme that I have now.


Right below the metadata is the facebook and twitter card section - you can add images there. :slight_smile:

Different themes handle cover images differently, and then on top of that, Ghost uses the image in the metadata for the site. I’d try the facebook and twitter images first to see if that gets you the sharing behavior you want, and if that doesn’t work, consider loading the image (under design & branding) but then using some css to stop it from showing up in the background of the page.
(Might also be worth checking if the theme has a setting that prevents that behavior - it might.) It’s probably an easy css tweak, but I’d have to see it live with the image to tell you how to suppress it.

Thank you, it’s working now. I can only assume that even though I uploaded a default photo, if an individual post is ever shared, then it will use the post’s photo instead of the default photo.

That should be the case, yes!