'From' field in sent emails not taking the same value as 'From' field in config file

A similar issue has been raised before, though I thought the other threads were too messy and outdated so I decided to create a new one.

Changing the ‘from’ field in the json file does not change the actual ‘form’ field in emails sent by mailgun.

URL: adventgineering.org
Ghost version: 4.5.0
Configuration: DigitalOcean Droplet, using Mailgun SMTP
Console error: None

Steps to replicate:

  1. Add address to Ghost in admin panel:

  2. Add address to the config.production.json file, and run ghost restart:

  3. Subscribe with another email.

  4. Mail still shows up as ‘adventgineering’ on the receiving end:
    The email newsletter preview shows up wrongly as well:
    Settings > Email Newsletter > Customize (in ‘Email Design’)

Things I’ve tried:

  1. Changing the email address in step 1 to 'Jia Yang' <jy@adventgineering.org> (got a ‘Retry’ error)

  2. Looked at related threads at here and here. There didn’t seem to be a way to solve this issue.

  3. Checked in mailgun API - sending using curl straight from the console with the correct settings works.

Any suggestions? Or is this a known bug?