Members login fails with no information

I can’t login to the member account when i click the login link. Everything is fine with the login email, but when i click the login button in the email, it just open the home page of my blog, still not login and shows no information or warning.
But When I check the member activity record in the admin panel, it shows i have logged in correctly.

Now I have tried changing my theme and add some CDN rules to prevent api being cached, is there anything that i do wrong or missed?

  • How was Ghost installed and configured?
    Installed with docker-compose,here is the configured files:
version: '3.1'


    image: ghost:latest
      - /www/ghost:/var/lib/ghost/content
    restart: always
      - 8080:2368
      # see
      database__client: mysql
      database__connection__host: db
      database__connection__user: ***
      database__connection__password: ***
      database__connection__database: ghost
      # this url value is just an example, and is likely wrong for your environment!
      # contrary to the default mentioned in the linked documentation, this image defaults to NODE_ENV=production (so development mode needs to be explicitly specified if desired)
      #NODE_ENV: development

    image: mysql:8.0
    restart: always
  • What Node version, database, OS & browser are you using?
  • Database: mysql8
  • What errors or information do you see in the console?
[2023-06-25 01:59:01] e[36mINFOe[39m "GET /members/?token=d_3t5vQnPLiJThYaaGkqjfvWXRjTtDW9&action=signin" e[36m302e[39m 94ms
[2023-06-25 01:59:02] e[36mINFOe[39m "GET /?action=signin&success=true" e[32m200e[39m 428ms
[2023-06-25 01:59:04] e[36mINFOe[39m "GET /members/api/member/" e[32m204e[39m 2ms
[2023-06-25 01:59:04] e[36mINFOe[39m "GET /ghost/api/content/settings/?key=25bc5250c9a54fc1f0725f3695&limit=all" e[32m200e[39m 40ms
[2023-06-25 01:59:04] e[36mINFOe[39m "GET /ghost/api/content/tiers/?key=25bc5250c9a54fc1f0725f3695&limit=all&include=monthly_price,yearly_price,benefits" e[32m200e[39m 37ms
[2023-06-25 01:59:04] e[36mINFOe[39m "GET /ghost/api/content/newsletters/?key=25bc5250c9a54fc1f0725f3695&limit=all" e[32m200e[39m 51ms
  • What steps could someone else take to reproduce the issue you’re having?
    click and sign up, click the magic link that send to your email, then you’ll find you’re still not login.

It’s been a while since you asked this. Were you able to get it resolved?

Sadly no. I’ve known the cause of problem is the Bunny CDN, but I still can’t fix the problem. Now I have change the CDN provider to avoid the problem.

It sounds like the magic link is emailed ok but the url including the query string is getting lost during the redirect maybe? Or the cookie isn’t getting set?