Email Received is a different email than my "From" email in Admin Area

I’m not sure I follow lol. Sorry. I don’t know if I have an actual email address on this domain. When I did the one click install from Digital Ocean, it came pre populated with noreply@n0sec.tech. But then I added the Mailgun integration.

So now I’m confused what From address goes in the config and what From address goes in the Dashboard. I don’t have any mail configured on the server I don’t think. How would I check?

If it doesn’t need to exist how do I get it to save? It keeps prompting me to confirm the email address

Ok, it doesn’t really matter about the config right now. Let’s focus on the members panel.

Your from email doesn’t need to exist if you don’t want replies coming back to it. So n0reply@n0sec.tech is fine. Move down a box to the Mailgun integration and enter your API, select your region and enter your Mailgun domain. The one in your SMTP credentials mail.n0sec.tech? Pop that in there, test it.

EDIT: That’s just the domain name, not the SMTP email address

That didn’t fix it either.

So here’s where I am. I have the same config that I posted above. I have tried to make the From address in the dashboard “noreply@n0sec.tech”. Everytime that I do it sends a verification email and asks me to confirm the email address.

I have added my Mailgun domain and Public Key to the API Key field.

The From address is stuck now at my Gmail address from earlier and I can’t change it because it prompts for verification each time

I’m confused with this. Maybe someone else can tap in and help you out? @DavidDarnes I don’t have nearly as much knowledge with this as you, can you help this guy?

It would be really helpful for everyone if you could’ve filled in the initial template that’s given when creating a new topic. Here’s the questions again:

  • What’s your URL?
  • What version of Ghost are you using?
  • What configuration?
  • What browser?
  • What errors or information do you see in the console?
  • What steps could someone else take to reproduce the issue you’re having?

Thanks! :blush:

My issue is kinda really specific. I’m trying to set up Maligun to work so I can send newsletters out but as the other posts have mentioned, the From address in the email is formatted very strangely and it’s doing it for every From address

I changed the From address in the dashboard to a personal Gmail account and it still did the strange formatting (see the pictures in the thread) and now will not let me change the From address in the dashboard back to what it originally was, noreply@n0sec.tech

I have configured my JSON file to what it needs to be, set up my DNS according to all documentation, checked propogation, added my Mailgun API key, and done all the steps necessary to set this up and it does work but now I have two main issues:

  1. I cannot save a different From address in the dashboard

  2. That From address gets formatted like you’ve seen in the pictures already attached to this thread

This is extremely frustrating as one user here as indicated it should not be doing this at all.

Thank you for your help.

The JSON config file, you mentioned a portion of it in a previous comment :slight_smile:

Ah okay!

Here it is.

I’m still having issues with this. This is not resolved. Can anybody assist please?

From the looks of your config file you’re still missing the from value. The from value is the from address for all of your transactional emails, you can read more about how to implement it here:

Try to use a real, working email address as this greatly improves delivery rates for important emails. You’ll need to run ghost restart to apply the new configuration options.

Additionally you can set a custom email for members newsletters, which can be done in the members settings and needs to be verified with a confirmation email.

Hope this helps!

Would I be able to buy an email mailbox from my domain registrar and use that email in the JSON config file? Then would I be able to do something like noreply@n0sec.tech in the dashboard? Ever time I change the email in the dashboard though, it sends an email out to confirm it and I can’t do that because I don’t have a noreply@n0sec.tech email address. Nor do I really know how to go about getting one.

If the from in both places needs to be real then what’s the point of even using Mailgun? I can’t receive emails there so I might as well just buy an email and use that, no? Am I going about this wrong?

Mailgun is a service designed for sending bulk emails, not an inbox tool. You should really create your email for real so it can be validated and optionally receive emails from your members. You can most likely set up a new email account with your domain provider

Has this issue been solved? I have the exact same problem and I cannot figure out what’s wrong. I run a self-hosted newsletter on DigitalOcean. I’d like to see the from address in my email client to be just “Sunday MashUp me@martinverbic.com” or something similar.

Some of my data:

My config.production.json file:

What I get when test sending an email:

What my Labs settings look like:

DNS settings are all properly propagated.

No, it was never solved lol.

1 Like

Is it solvable? Would be really nice if someone from Team Ghost told us :stuck_out_tongue: